Juno - Investigating and issue with Logging into Juno – Incident details

All systems operational

Investigating and issue with Logging into Juno

Resolved
Major outage
Started 4 months agoLasted about 9 hours

Affected

Juno Web Application

Major outage from 10:00 AM to 7:00 PM

Updates
  • Resolved
    Resolved

    AWS is fully back online and we are considering this incident resolved.

  • Investigating
    Investigating

    We are currently investigating reports of users having difficulty logging into Juno. We believe this to be related to the AWS outages that are publicly known. We will provide updates the moment we know more.