Juno - Investigating and issue with MFA login to the Juno Integration App – Incident details

All systems operational

Investigating and issue with MFA login to the Juno Integration App

Resolved
Partial outage 0 %
Started about 1 month agoLasted about 6 hours

Affected

Juno Web Application

Operational from 2:05 PM to 8:05 PM

Juno Integration Application

Partial outage from 2:05 PM to 8:05 PM

Juno Support

Operational from 2:05 PM to 8:05 PM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved. If you see any further issues please open a ticket with our support team via support@juno.tax.

  • Monitoring
    UTC
    Monitoring

    We have implemented a fix for the current issue and will be monitoring the results. If you see any login issues, please reach out to support via live chat or support@juno.tax. Once we are satisfied that the issue is fully resolved we will change the status.

  • Identified
    UTC
    Identified

    We have identified the issue with MFA login through to the Juno Integration App and are working on implementing a fix. We will update here the moment we have a fix in place.

  • Investigating
    UTC
    Investigating

    We are currently investigating reports of errors when attempting to use MFA login to the Juno Integration App. We will provide updates the moment we know more.